Resolved -
The issue is now resolved. Thank you for your patience.
Mar 20, 18:35 UTC
Monitoring -
All of the Articulate 360 services are operational! We'll continue to monitor performance.
Mar 20, 15:53 UTC
Investigating -
Hi Articulate 360 users,
We're investigating an issue causing occasional errors or timeouts when accessing multiple Articulate 360 applications. We apologize for the inconvenience and are actively working on a fix.
We'll provide updates as soon as more information is available.
Mar 20, 15:44 UTC