All Systems Operational

Articulate 360 Operational
90 days ago
99.99 % uptime
Today
Rise 360 Operational
90 days ago
99.94 % uptime
Today
Review 360 Operational
90 days ago
99.99 % uptime
Today
Reach 360 Operational
90 days ago
100.0 % uptime
Today
Team Slides Operational
90 days ago
100.0 % uptime
Today
Articulate 360 Desktop App Updates Operational
90 days ago
100.0 % uptime
Today
Storyline 360 Text to Speech Operational
90 days ago
100.0 % uptime
Today
Articulate 360 Training Operational
90 days ago
100.0 % uptime
Today
Content Library 360 Operational
Content Library Images 360 Operational
Account Management Operational
AI Assistant Operational
90 days ago
100.0 % uptime
Today
AI Images Operational
90 days ago
100.0 % uptime
Today
Localization Operational
90 days ago
99.99 % uptime
Today
Articulate ID Operational
90 days ago
100.0 % uptime
Today
E-Learning Heroes Operational
90 days ago
100.0 % uptime
Today
Articulate.com Operational
Operational
Degraded Performance
Partial Outage
Major Outage
Maintenance
Major outage
Partial outage
No downtime recorded on this day.
No data exists for this day.
had a major outage.
had a partial outage.

Scheduled Maintenance

Articulate Systems Maintenance: Account Management and E-commerce Apr 26, 2025 04:30-06:00 UTC

Articulate will be making updates to our internal systems on Friday, April 25, 2025, starting at 11:30 p.m. ET. It should take about 1.5 hours. During this time, you won’t be able to buy new subscriptions or add seats to your existing subscription. We'll let you know as soon as we're done!
Posted on Apr 22, 2025 - 19:41 UTC
Apr 24, 2025

No incidents reported today.

Apr 23, 2025

No incidents reported.

Apr 22, 2025
Resolved - Content Library 360 images are now working normally, and this incident is resolved.
Apr 22, 14:27 UTC
Monitoring - Hi Content Library Users! You may be experiencing latency issues when loading Content Library images. We are aware of this and monitoring the issue. This is affecting Rise 360, Storyline 360 and Rise.com. Apologies for the trouble.
Apr 21, 23:27 UTC
Apr 21, 2025
Apr 20, 2025

No incidents reported.

Apr 19, 2025
Completed - The scheduled maintenance has been completed.
Apr 19, 08:00 UTC
In progress - Scheduled maintenance is currently in progress. We will provide updates as necessary.
Apr 19, 01:30 UTC
Scheduled - Articulate will be making updates to our internal systems on Friday, April 18, 2025, starting at 9:30 p.m. ET. It should take about 6.5 hours. During this time, you won’t be able to buy new subscriptions or add seats to your existing subscription. We'll let you know as soon as we're done!
Apr 11, 20:10 UTC
Apr 18, 2025

No incidents reported.

Apr 17, 2025

No incidents reported.

Apr 16, 2025

No incidents reported.

Apr 15, 2025

No incidents reported.

Apr 14, 2025

No incidents reported.

Apr 13, 2025

No incidents reported.

Apr 12, 2025

No incidents reported.

Apr 11, 2025

No incidents reported.

Apr 10, 2025

No incidents reported.