All Systems Operational
Articulate 360 Operational
90 days ago
99.99 % uptime
Today
Rise 360 Operational
90 days ago
99.94 % uptime
Today
Review 360 Operational
90 days ago
99.99 % uptime
Today
Reach 360 Operational
90 days ago
99.99 % uptime
Today
Team Slides Operational
90 days ago
100.0 % uptime
Today
Articulate 360 Desktop App Updates Operational
90 days ago
100.0 % uptime
Today
Storyline 360 Text to Speech Operational
90 days ago
100.0 % uptime
Today
Articulate 360 Training Operational
90 days ago
100.0 % uptime
Today
Content Library 360 Operational
Content Library Images 360 Operational
Account Management Operational
AI Assistant Operational
90 days ago
100.0 % uptime
Today
AI Images Operational
90 days ago
100.0 % uptime
Today
Localization Operational
90 days ago
99.99 % uptime
Today
Articulate ID Operational
90 days ago
100.0 % uptime
Today
E-Learning Heroes Operational
90 days ago
100.0 % uptime
Today
Articulate.com Operational
Operational
Degraded Performance
Partial Outage
Major Outage
Maintenance
Major outage
Partial outage
No downtime recorded on this day.
No data exists for this day.
had a major outage.
had a partial outage.
Scheduled Maintenance
Scheduled Maintenance: Articulate 360 Mar 15, 2025 01:00-04:00 UTC
Hi all! On Saturday, March 15th from 8 pm EST to 11 pm EST, all localization features in Rise 360 and Storyline 360 will be unavailable while we undergo maintenance. During this time, you may see a “Translation Failed” error. We’ll let you know as soon as the maintenance is complete!
Posted on Feb 28, 2025 - 21:06 UTC
Articulate will be making updates to our internal systems on Friday, March 14, 2025, starting at 9:30 p.m. ET. It should take about 8.5 hours. During this time, you won’t be able to buy new subscriptions or add seats to your existing subscription. We'll let you know as soon as we're done!
Posted on Mar 10, 2025 - 16:06 UTC
Past Incidents
Mar 12, 2025

No incidents reported today.

Mar 11, 2025
Resolved - Rise 360 is performing normally, and this issue has been resolved.
Mar 11, 15:48 UTC
Monitoring - Rise 360 access has been restored and is fully functional. If you're still experiencing an issue, please reach out to our Support team support@articulate.com.
Mar 11, 15:09 UTC
Investigating - Hi, all! We’re aware of an issue affecting Rise 360 Dashboard and Rise Authoring. Our team is actively investigating and working to resolve the issue as quickly as possible. We’ll provide updates as we have more information. Thank you for your patience.
Mar 11, 14:49 UTC
Monitoring - We are pleased to report that Rise 360 access has been restored and is fully functional. If you're still experiencing an issue, please reach out to our Support team support@articulate.com.
Mar 11, 13:58 UTC
Investigating - We’re aware of an issue affecting Rise 360 Dashboard and Rise Authoring. Our team is actively investigating and working to resolve the issue as quickly as possible. We’ll provide updates as we have more information. Thank you for your patience.
Mar 11, 12:57 UTC
Mar 10, 2025

No incidents reported.

Mar 9, 2025

No incidents reported.

Mar 8, 2025

No incidents reported.

Mar 7, 2025

No incidents reported.

Mar 6, 2025

No incidents reported.

Mar 5, 2025

No incidents reported.

Mar 4, 2025

No incidents reported.

Mar 3, 2025

No incidents reported.

Mar 2, 2025

No incidents reported.

Mar 1, 2025

No incidents reported.

Feb 28, 2025

No incidents reported.

Feb 27, 2025

No incidents reported.

Feb 26, 2025

No incidents reported.