All Systems Operational
Articulate 360 Operational
90 days ago
99.94 % uptime
Today
Rise 360 Operational
90 days ago
99.94 % uptime
Today
Review 360 Operational
90 days ago
99.94 % uptime
Today
Reach 360 Operational
90 days ago
99.98 % uptime
Today
Team Slides Operational
90 days ago
99.94 % uptime
Today
Articulate 360 Desktop App Updates Operational
90 days ago
99.94 % uptime
Today
Storyline 360 Text to Speech Operational
90 days ago
99.94 % uptime
Today
Articulate 360 Training Operational
90 days ago
99.94 % uptime
Today
Content Library 360 Operational
Content Library Images 360 Operational
Account Management Operational
AI Assistant Operational
90 days ago
99.88 % uptime
Today
AI Images Operational
90 days ago
99.87 % uptime
Today
Articulate ID Operational
90 days ago
99.9 % uptime
Today
E-Learning Heroes Operational
90 days ago
99.98 % uptime
Today
Articulate.com Operational
Operational
Degraded Performance
Partial Outage
Major Outage
Maintenance
Major outage
Partial outage
No downtime recorded on this day.
No data exists for this day.
had a major outage.
had a partial outage.
Scheduled Maintenance
Articulate will be making updates to our internal systems on Friday, October 18, 2024, starting at 9:00 p.m. ET. It should take about 10 hours. During this time, you won’t be able to buy new subscriptions or add seats to your existing subscription. We'll let you know as soon as we're done!
Posted on Oct 16, 2024 - 13:17 UTC
Scheduled Maintenance: Articulate 360 Oct 27, 2024 00:00-03:00 UTC
Hi there, Articulate 360 users. We'll be doing some Articulate 360 maintenance on Saturday, October 26th, 2024, from 8 PM to 11 PM Eastern. Articulate 360 services may be degraded or down during this time. We'll let you know as soon as we're done!
Posted on Oct 02, 2024 - 14:38 UTC
Past Incidents
Oct 18, 2024

No incidents reported today.

Oct 17, 2024

No incidents reported.

Oct 16, 2024

No incidents reported.

Oct 15, 2024

No incidents reported.

Oct 14, 2024

No incidents reported.

Oct 13, 2024

No incidents reported.

Oct 12, 2024

No incidents reported.

Oct 11, 2024

No incidents reported.

Oct 10, 2024

No incidents reported.

Oct 9, 2024

No incidents reported.

Oct 8, 2024

No incidents reported.

Oct 7, 2024

No incidents reported.

Oct 6, 2024

No incidents reported.

Oct 5, 2024

No incidents reported.

Oct 4, 2024

No incidents reported.